Unabke to connect to Google


I cannot connect to Google from the game.

When I try I get the error message "Unable to connect to Google Play Sevices. If the problem persists please restart the game."

At the same time in the top of the screen the Google symbol appears saying authentication successful.

I have restarted the game and my tablet several times. 


  • Hi Anders,

    I suggest you recreate the Google Play connection.

    Try these steps:

    1. Go to System settings
    2. Click on Google
    3. Click on Connected apps
    4. Locate Solgard and click on Disconnect
    5. In the dialog box click on Disconnect
    6. Return to the System settings
    7. Click on Apps
    8. Locate Solgard and click on Storage
    9. Clear the cache
    10. Reboot your device
    11. Start the game and you should now be able to connect correctly to Google Play
  • Hi Mark,

    Thank you for the easy-to-follow instruction.It failed when I cleared the Solgard cache, but when I tried without clearing and rebooting it worked.

    Thank you!Anders

  • Hi there Anders,

    Good to hear you got the problem solved : )

    - Mark

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


This Week's Leaders