What devices are compatible with Legend of Solgard?

Legend of Solgard supports most devices that use:

  • Android 4.4 or above
  • iOS 9.0 or above

We support devices with at least 2 GB of RAM and 32 GB Storage.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Leaderboard

This Week's Leaders